8 hp briggs snowblower engine dies

Reply

  #1  
Old 01-08-09, 02:49 AM
Member
Thread Starter
Join Date: Jan 2009
Location: Canada
Posts: 1
8 hp briggs snowblower engine dies

Good day,

I have a snowblower with an 8HP B&S horizontal shaft engine, regular type valves (not OHV). 19400 series.

The engine dies after 1-5 minutes running, sometimes runs for 20 minutes ! It always starts cold, always has plenty of fuel to the carb and everytime I remove the plug after it stalls, I see white sparks upon cranking.

I tore down the carb, soaked it 12 hours, put in all new B&S carb kit parts, checked the float adjustment. I adjusted both new idle and high speed carb screws to nominal. Tank cap vents well...

Have you got a suggestion for troubleshooting, I am at the end of my wits and it is snowing...

Sylvain
 
Sponsored Links
  #2  
Old 01-08-09, 04:35 AM
Join Date: Jan 2007
Location: MA
Posts: 514
Would have been better to start a new thread, this one is 2 1/2 years old.

I am guessing this is a 2 piece flo jet carb. Did you replace the main nozzle? You may have installed needle on the float wrong. the open end of the clip where it attaches to the needle needs to be facing away from fuel inlet.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes