Welcome to the DoItYourself Forums!

To post questions, help other DIYers and reduce advertising (like the one on your left), join our DIY community. It's free!

Craftsman Chainsaw won't idle


jbh327's Avatar
Member

Join Date: Jan 2009
Posts: 20

01-16-09, 07:03 PM   #1  
Craftsman Chainsaw won't idle

I have a Craftsman chainsaw that I can't keep running at idle. It dies instantly when i let off the throttle, or i can bump the throttle down to an idle but it only runs for a few more seconds before dying. I've changed the air filter, plug, gas mix, and diaphram; and checked the fuel lines and filter. They seem fine. It has a Walbro Wt-120 carb. I tried adjusting the low speed idle, but that didn't make much difference. Can anyone give me some ideas on what to try next?

 
Sponsored Links
cheese's Avatar
Forum Topic Moderator

Join Date: Jul 2001
Posts: 16,567
GA

01-16-09, 09:22 PM   #2  
You said you adjusted the low speed idle. I am assuming that means the idle speed screw? It sounds like you might want to open up the low speed mixture screw a little.


"Who is John Galt?" - Ayn Rand (Atlas Shrugged)

God bless!

 
Airman's Avatar
Member

Join Date: Feb 2008
Posts: 755
TN

01-17-09, 07:02 AM   #3  
At the Walbro link below you can download a manual for your carburetor. In addition to the "WT" manual get the "Diaphragm Carburetors" manual.

Service Manuals

 
jbh327's Avatar
Member

Join Date: Jan 2009
Posts: 20

01-19-09, 07:12 PM   #4  
Looks like I just needed to do alittle more adjusting. Thanks for your help, guys.

 
BuckRivet's Avatar
Member

Join Date: Jan 2009
Posts: 6

01-23-09, 09:41 AM   #5  
make sure the exhaust port/spark arrestor isnt clogged with sawdust etc. too much back pressure will make them not idle

 
Search this Thread