Welcome to the DoItYourself Forums!

To post questions, help other DIYers and reduce advertising (like the one on your left), join our DIY community. It's free!

350 husqvarna chain oiler problem


goldbeachoutlaw's Avatar
Member

Join Date: Feb 2009
Posts: 2

02-03-09, 06:45 PM   #1  
350 husqvarna chain oiler problem

the chain oiler on my husky quit working and i can't seem to get it working again. i've disassembled and cleaned everthing
checked the pump and it seems to pump a little oil(how much should it put out when turning it by hand?)when i run the saw it drips oil out the bottom of the saw, but only throws oil off the chain when i turn it sideways with the oil tank filler up. is there a vent in the oil tank? i just got a new cap from the dealer for it, could it be the wrong one(dealer knows the saw so it should be right.i can't see anything that looks bad inside, i took the oiler out and examined everthing to no avail. is the pump shot? thanx bob

 
Sponsored Links
cheese's Avatar
Forum Topic Moderator

Join Date: Jul 2001
Posts: 16,573
GA

02-03-09, 08:56 PM   #2  
Is the hole in the bar clogged up?


"Who is John Galt?" - Ayn Rand (Atlas Shrugged)

God bless!


Last edited by cheese; 02-15-09 at 06:21 PM.
 
goldbeachoutlaw's Avatar
Member

Join Date: Feb 2009
Posts: 2

02-15-09, 12:47 PM   #3  
hole is clear, on both sides.

 
Airman's Avatar
Member

Join Date: Feb 2008
Posts: 755
TN

02-15-09, 01:37 PM   #4  
Have you tried adjusting oil flow?

Could be trash in the oil tank, pickup, lines or pump. Drain and wash out all with mineral spirits. The manual below covers disassembly and assembly.

Here is a link to a service manual.
http://www.gardening-tools-direct.co...1019026-26.pdf

 
Search this Thread