Starting Trouble with Briggs Engine

Reply

  #1  
Old 02-14-09, 02:46 PM
Member
Thread Starter
Join Date: Feb 2009
Location: Missouri
Posts: 1
Starting Trouble with Briggs Engine

Me and a couple of my reletives have Riding Lawnmowers with Briggs engines and over a couple of years they all have trouble starting now. They act like the compression has doubled or something and you have to hand turn the flywheel until it gets to the right spot before it will turn over. After doing this for awhile it will finally turn over and start

Can anyone help here, after the first mower did it I didnt think much about it but we have three of them now that take forever to get running. Its like the compression is too high!
I think they are 12 or 14 horse

Help!! Thank you!
 
Sponsored Links
  #2  
Old 02-14-09, 04:31 PM
Member
Join Date: Jul 2006
Location: Central New Hampshire
Posts: 754
Please post engine model numbers
 
  #3  
Old 02-14-09, 04:41 PM
Member
Join Date: Jul 2006
Location: Central New Hampshire
Posts: 754
Check the flywheel key. If they are cracked or broken, your timing will be off causing the engine to want to fire at the wrong time.
 
  #4  
Old 02-14-09, 07:31 PM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 16,575
You need to adjust the valves. Set the engine at 1/4" past TDC, and then set both valve clearances at .005".
 
Reply


Thread Tools
Search this Thread
Display Modes
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -7. The time now is 09:32 AM.