pressure cleaner crank/coil problem

Reply

  #1  
Old 03-08-09, 10:08 AM
Member
Thread Starter
Join Date: Mar 2009
Location: Florida
Posts: 1
Unhappy pressure cleaner crank/coil problem

Hi everyone - I have a Troy Bilt/Briggs stratton 2550 PSI pressure washer 675 series model 020337- the problem is the coil (stater cord) seems jammed . If I pull it out slow in little jerks it will eventually come out to full length . I made sure the cord wasnt twisted and slowly let it recoil. It allowed one smooth "start" pull but when it recoiled it wouldnt allow another pull. It feels jammed and like its going to snap. Hope I explained it clearly . Can anyone tell me whats wrong. It only been used like 4 times. Thank you so much for your help
 
Sponsored Links
  #2  
Old 03-08-09, 12:45 PM
waterwelldude's Avatar
Member
Join Date: Jun 2008
Location: S.E. Texas
Posts: 1,039
The pressure regulator may be bad or going bad.
Mine did the same thing.
After one pull it would not pull hardly at all.
I let the pressure off, and it would pull normal.

If you squeeze the handle after each pull, does the do anything? It should make it easier to pull.


Travis
 
  #3  
Old 03-08-09, 02:09 PM
Member
Join Date: Mar 2009
Location: all
Posts: 14
i had problem with mine and and found out the sheer pin on my flywheel had snapped,worth checking as there only made of aluminum,good luck
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes