Welcome to the DoItYourself Forums!

To post questions, help other DIYers and reduce advertising (like the one on your left), join our DIY community. It's free!

electric clutch problems


rokytop1's Avatar
Member

Join Date: Mar 2009
Posts: 1

03-15-09, 04:28 AM   #1  
electric clutch problems

I have a craftsman gt3000 46in w/ 23hpbriggs. Last year ,late in the season the pto switch melted at the end of the stem while I was mowing of course the blades disengaged. I removed the switch and jumped it out. The mower started w/ blades engaged. mowed a while and the blade clutch diaengaged. Thinking the clutch was bad I installed a new switch and a new electric blade clutch. Everything worked fine for a couple of mowings and the the pull switch melted again at the end of the stem, plastic you know. Hopefully someone can help direct me to the root of the problem Thank you

 
Sponsored Links
hopkinsr2's Avatar
Member

Join Date: Feb 2005
Posts: 1,561
Non-US

03-15-09, 08:48 AM   #2  
Is the switch the proper one for the mower, or a generic replacement. Make sure the switch is heavy enough to handle the currant draw of the clutch. Some aftermarket switches are only rated for 2 or 3 amps to operate a relay for the heavy load (as in a fog light circuit). Also check the charging system to make sure it's not overcharging. Have you had this unit since new, Or just bought it?? Roger.

 
cheese's Avatar
Forum Topic Moderator

Join Date: Jul 2001
Posts: 16,574
GA

03-15-09, 08:36 PM   #3  
Check the wiring and connector at the plug of the switch on the mower harness. I'd say you have a bad connection there. Either a terminal does not fit tight, or is corroded, etc...


"Who is John Galt?" - Ayn Rand (Atlas Shrugged)

God bless!

 
Search this Thread