JD SRX75 riding mower dies and no gas past fuel filter

Reply

  #1  
Old 03-18-09, 12:01 PM
Member
Thread Starter
Join Date: Mar 2009
Posts: 4
JD SRX75 riding mower dies and no gas past fuel filter

I own a JD SRX75 riding mower and it runs fine for 15-20 minutes and then dies. After waiting about 10-15 minutes it will crank, but it will die shortly after that again. We have drained the fuel tank and gas is getting from the tank through the fuel filter just fine. However, gas is not getting to the carbeurator very well. Please help!
 
Sponsored Links
  #2  
Old 03-18-09, 01:23 PM
Member
Join Date: Jul 2006
Location: Central New Hampshire
Posts: 754
runs 15 mins then dies then will start again after 15 min. cool down then dies again. This sounds like the coil is getting hot. May need a new coil.
 
  #3  
Old 03-18-09, 07:40 PM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 16,821
That's along the lines I was thinking too. Check for spark when it dies.
 
  #4  
Old 03-18-09, 08:01 PM
Member
Thread Starter
Join Date: Mar 2009
Posts: 4
We were thinking the problem was that it wasn't getting enough gas. What would be the problem there?
 
  #5  
Old 03-18-09, 08:07 PM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 16,821
Could be several things, but why do you think it's not getting gas? Have you checked anything that would lead you to believe it isn't getting gas?
 
  #6  
Old 03-19-09, 09:47 AM
Member
Thread Starter
Join Date: Mar 2009
Posts: 4
It appears to have little to no gas running through the filter, should it be full while running?
 
  #7  
Old 03-19-09, 10:18 AM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 16,821
No...the amount of gas in the filter, running or not, makes no difference.
 
  #8  
Old 03-19-09, 10:36 AM
Member
Thread Starter
Join Date: Mar 2009
Posts: 4
Apparently the spark plug has been tested and it fires, so the coil isn't the problem. It is now believed that the gas is not getting to the carbeurator. I put a new filter in the carb. Any new suggestions?
 
  #9  
Old 03-19-09, 01:46 PM
Member
Join Date: Jul 2006
Location: Central New Hampshire
Posts: 754
Originally Posted by jaiime23 View Post
Apparently the spark plug has been tested and it fires, so the coil isn't the problem. It is now believed that the gas is not getting to the carbeurator. I put a new filter in the carb. Any new suggestions?
Was is tested immediately after it died? That's when you need to test it.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes