Craftsman riding mower won't roll in netural

Reply

  #1  
Old 03-28-09, 11:29 AM
Member
Thread Starter
Join Date: Mar 2009
Posts: 2
Craftsman riding mower won't roll in netural

My Craftsman 18.5 hp mower was cutting fine and then stalled. Each time it was restarted it would stall when the clutch was engaged. That is when I realized it would not roll either. With the engine turned off, and the transmission in neutral, the mower could not be rolled the least bit. I tried to restart the engine but this time it never fired. The starter and engine turn over just fine but it never fires. I had to put hand-trucks under the rear wheels to pull the mower back into the garage.
I really need some help. Not looking for sympathy please....but I have been laid off and the wife only works part time so I have got to fix this myself. I am somewhat mechanic and small engine literate but I can quickly get over my head. Any help will be greatly appreciated. I was hoping to make a little money this spring doing lawns till I can find a job. Again, please don't feel sorry for me for so many people are in a lot worse shape. I am blessed with great friends and family. Thank you so much for your help.
 
Sponsored Links
  #2  
Old 03-28-09, 12:51 PM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 16,819
Is your mower hydro or standard shift? I'd start by looking at the brake on the side of the tranny and see if it's stuck. That's the most common cause of your problem.

I hope your situation improves soon. A lot of folks in rough times right now . God bless!
 
  #3  
Old 03-28-09, 06:54 PM
Member
Thread Starter
Join Date: Mar 2009
Posts: 2
It's a hydro.

Thanks, I'll check the brake.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes