Craftman 4 cycle Weedwacker

Reply

  #1  
Old 04-07-09, 07:07 AM
Member
Thread Starter
Join Date: Jul 2005
Location: Texas
Posts: 205
Craftman 4 cycle Weedwacker

Customer brought me this trimmer for repair,it would not start.It has 90# of compression,and has a good spark.I can put some fuel in the spark plug hole,and it will run and die.I can also spray some carb. cleaner in the carb.and it will run and die.I overhaul the carb.with a new kit,and have took it apart twice and sprayed it with carb. cleaner still no gas to plug.I have replace the fuel lines and filter.I getting gas to the primer bulb when I press it.The lines are not crossed.the carb.WYL148.Model#358.796121.Sorry for the long thread.

Thanks,
Jerry
 
Sponsored Links
  #2  
Old 04-07-09, 09:25 AM
Member
Join Date: Jun 2006
Location: St. Louis
Posts: 2,365
Sounds like an air leak, tighten all the crankcase bolts, also check that the insulator between the carb and crankcase isn't cracked. If you can keep it running long enough, spray some carb cleaner along the mating surfaces to see if the engine tempo changes indicating a leak. Have a good one. Geo
 
  #3  
Old 04-08-09, 02:57 PM
Member
Thread Starter
Join Date: Jul 2005
Location: Texas
Posts: 205
geogrubb,you hit the nail right on the head.Check the insulator was not crack,but the gasket between the insulator and the head was bad,replaced it,now the trimmer runs great.

Thanks,
Jerry
 
  #4  
Old 04-08-09, 03:07 PM
Member
Join Date: Jun 2006
Location: St. Louis
Posts: 2,365
Success is a wonderful sound. Have a good one. Geo
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes