Welcome to the DoItYourself Forums!

To post questions, help other DIYers and reduce advertising (like the one on your left), join our DIY community. It's free!

Craftsman Ride-On Mower Won't Start


lewbeach's Avatar
Member

Join Date: Apr 2009
Posts: 3

04-20-09, 05:16 PM   #1  
Craftsman Ride-On Mower Won't Start

I have a ten year old Craftsman mower. It ran fine a week ago. This week, won't start. It has a new battery and the starter works when connected directly to battery. When I turn the key I get a small click at the carborator but nothing else. The blades are disengaged, clutch press in, and I'm sitting on the seat. I have a feeling it is on of those safety relays but, I can't find them and don't know how to test them.

 
Sponsored Links
hopkinsr2's Avatar
Member

Join Date: Feb 2005
Posts: 1,561
Non-US

04-20-09, 08:18 PM   #2  
I'm not too familliar with the Craftsman mowers, but they all can be different depending on what you have.. If you post some engine & mower model & serial numbers, I'm sure the Pro's will help you out.. Also any other features it may have.. Good luck,,, Roger

 
cheese's Avatar
Forum Topic Moderator

Join Date: Jul 2001
Posts: 16,570
GA

04-20-09, 08:51 PM   #3  
Check the white wire on the solenoid for power when trying to start it. If 12 volts is present, the solenoid is bad. If it is not present, post model #...you likely have a safety switch problem or relay problem (if equipped).


"Who is John Galt?" - Ayn Rand (Atlas Shrugged)

God bless!


Last edited by cheese; 06-06-09 at 08:25 PM.
 
lewbeach's Avatar
Member

Join Date: Apr 2009
Posts: 3

04-21-09, 03:30 AM   #4  
The Model# is 917255725. I think I bought it in 1999.

 
lewbeach's Avatar
Member

Join Date: Apr 2009
Posts: 3

04-28-09, 05:00 AM   #5  
It worked!

I did the recommended check for 12V on the white wire at the solenoid. I got 12V when turning the ignition. Replaced the solenoid. Works like a charm! Thanks.

 
cheese's Avatar
Forum Topic Moderator

Join Date: Jul 2001
Posts: 16,570
GA

04-28-09, 10:31 PM   #6  
Great! Glad we could help and thanks for the update!


"Who is John Galt?" - Ayn Rand (Atlas Shrugged)

God bless!

 
monster1's Avatar
Banned. Rule And/Or Policy Violation

Join Date: May 2009
Posts: 1

05-09-09, 05:54 AM   #7  
any solution yet

hi i am having same problem and would like to have the electricschematic or pin point where are the fuses if any and all the safety relays and switches beside the one under the seat. My craftsman model# 917272761 b&s engine

 
cheese's Avatar
Forum Topic Moderator

Join Date: Jul 2001
Posts: 16,570
GA

05-10-09, 12:09 AM   #8  
The fuse is near the battery cable where it meets the solenoid, coming from the same connection, inline in a red thin wire.


"Who is John Galt?" - Ayn Rand (Atlas Shrugged)

God bless!

 
Search this Thread