Craftsman Pressure Washer 580-752800 - Pressurized Eductor

Reply

  #1  
Old 04-26-09, 09:03 AM
Member
Thread Starter
Join Date: Mar 2009
Location: Midwest
Posts: 4
Angry Craftsman Pressure Washer 580-752800 - Pressurized Eductor

I have a Craftsman 580-752800 pressure washer that is passing pressure through the eductor and blowing the soap hose off the pump. The pressure is there the moment the water is turned on from the faucet and increases to operating pressure when the pressure washer engine is running. I have pulled the pump apart and did not see any O rings pinched. The ball check under the large adjustable spring was stuck but is now free. Any suggestions out there?
 
Sponsored Links
  #2  
Old 04-26-09, 10:32 AM
Member
Join Date: Mar 2009
Location: British Columbia
Posts: 111
There is a check valve in the tee that is stuck open. If you cannot disassemble the fitting, replace it.
 
  #3  
Old 04-26-09, 10:40 AM
Member
Thread Starter
Join Date: Mar 2009
Location: Midwest
Posts: 4
Where is the T

Is the T you are refering to at the point where the chemical feed line attaches to the pump?
 
  #4  
Old 04-27-09, 12:28 AM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 16,814
The fitting that the soap hose pushes onto should be removable, and there is a check ball and spring under it. This is the problem area. The check ball should not allow water to escape this fitting.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes