B&S Carburetor Solenoid problem

Reply

  #1  
Old 05-01-09, 12:07 PM
Member
Thread Starter
Join Date: May 2009
Location: Western NC
Posts: 6
B&S Carburetor Solenoid problem

I have a Bolens MTD 15.5 Lawn Tractor
Engine code 283H07 0197E1 030915ZE

The solenoid on the carburetor won't disengage and allow gas into the carb.

I have taken the solenoid off and checked it, it is clean and clear of debris, and will work when worked manually.

Also, tested it by connecting 2 wires to the mower battery and touching the contacts, the solenoid will function this way.

When connected to the terminal from the mower the solenoid will not work when switching the engine on.
Checked the voltage on the terminal with switch on and I am reading the same as on the battery, although the voltage is gradually going down a .01 volt at a time, as long as the switch is on.

The mower does turnover and will run when gas is poured in the air intake.

Thanks for any help in advance.

Great site by the way, I have a feeling I will be comming here a lot !!!
 
Sponsored Links
  #2  
Old 05-01-09, 03:42 PM
Member
Join Date: May 2006
Location: Iowa!!!!!
Posts: 3,728
You could just have a bad wire/wires leading to the solenoid. You could run a test wire out of the ignition switch and run the problem down that way.

If you get it to open, but it gradually closes, the solenoid itself could be bad.
 
  #3  
Old 05-01-09, 08:20 PM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 16,814
Does the ground wire at the solenoid have continuity to ground? Check voltage at the solenoid wire with the solenoid connected and see what it reads as well. If it works when you connect it to a battery, it is a good solenoid.
 
  #4  
Old 05-04-09, 01:52 PM
Member
Thread Starter
Join Date: May 2009
Location: Western NC
Posts: 6
I have a temporary fix in place, and was able to get the mower running, and was able to cut the grass, which made my wife very happy, she had mentioned something about the neighbors starting to talk !!!

I will try the suggestions below to see if I can get the solenoid to work, or decide that it is bad except when hooked directly to the battery.

I had already thought of just running a hot wire to from the battery to see if it would work when it is connected to the carb, but haven't done that yet either.

I found a place on line, that has the solenoid for $38, does this sound reasonable?
 
  #5  
Old 05-04-09, 05:21 PM
Member
Join Date: Apr 2009
Posts: 24
You could verify the problem as the solenoid by using a like threaded and length bolt, borrow the gasket from the solenoid and install the bolt in place of the solenoid.
Be certain to tape/tie/restrain the wire to the solenoid so it can not come into contact with a grounding surface.
 
  #6  
Old 05-04-09, 07:45 PM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 16,814
...or just clip the needle off the solenoid to render it ineffective.
 
  #7  
Old 05-06-09, 08:25 PM
Member
Join Date: May 2009
Location: Minnnesota
Posts: 1
where did you find a solenoid for 38 dollars and would it work on a 14hp kholer engine. thanks
 
  #8  
Old 05-08-09, 12:54 PM
Member
Thread Starter
Join Date: May 2009
Location: Western NC
Posts: 6
Originally Posted by Jbrokeit View Post
You could verify the problem as the solenoid by using a like threaded and length bolt, borrow the gasket from the solenoid and install the bolt in place of the solenoid.
Be certain to tape/tie/restrain the wire to the solenoid so it can not come into contact with a grounding surface.
Thats what I did, to get the mower to work.
 
  #9  
Old 05-08-09, 12:58 PM
Member
Thread Starter
Join Date: May 2009
Location: Western NC
Posts: 6
Originally Posted by cheese View Post
...or just clip the needle off the solenoid to render it ineffective.
Thought about doing that also.
 
  #10  
Old 05-08-09, 01:03 PM
Member
Thread Starter
Join Date: May 2009
Location: Western NC
Posts: 6
Originally Posted by abougeorge View Post
where did you find a solenoid for 38 dollars and would it work on a 14hp kholer engine. thanks
I didn't, I found one for a 15.5 Briggs & Stratton engine.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes