Old Snapper w/ 8 hp B & S won't start

Reply

  #1  
Old 05-07-09, 08:06 PM
Member
Thread Starter
Join Date: May 2009
Location: Northwest GA
Posts: 2
Unhappy Old Snapper w/ 8 hp B & S won't start

I have an old Snapper with a pull start 8 hp B & S engine. I started it up and got one circle around the yard with no problem and then it sputtered and died. Now it won't start. It's getting fire to the plug, although the spark isn't very big, but the plug was bone dry when I took it out, like there's no gas getting to it. It also has gas dripping from the carb when the inline cut off I installed is open. What would be the likely culprit? I appreciate any help you guys could give me. Thanks!
 
Sponsored Links
  #2  
Old 05-07-09, 09:02 PM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 16,814
The carb is in need of a thorough cleaning and rebuild with needle, seat, and possibly float if it has gas in it.
 
  #3  
Old 05-09-09, 05:42 AM
Member
Thread Starter
Join Date: May 2009
Location: Northwest GA
Posts: 2
Originally Posted by cheese View Post
The carb is in need of a thorough cleaning and rebuild with needle, seat, and possibly float if it has gas in it.
I suspected maybe trash in the carb. You just confirmed it! I appreciate it cheese, and have a blessed day.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes