Stihl FS55 Primer Bulb/Starting Problem

Reply

  #1  
Old 05-13-09, 05:39 AM
Member
Thread Starter
Join Date: May 2009
Location: NorthEast
Posts: 1
Stihl FS55 Primer Bulb/Starting Problem

hi -

I'm having trouble starting my FS55 weed trimmer. First thing I did was change the spark plug (man thats a tight fit with the wire in there!).

When I push the primer bulb, it stays pressed in and doesn't pop back up (there is fuel in it and the choke is on). After 45 min or so, its back to normal, and if I press it in, same thing happens.

I removed the 4 screws holding the bulb down and of course, this releases the vacuum. I pulled that plate off and the green fuel line off the brass L - fuel spilled out of the fuel line and I tried to push a wire into the brass L to see if there was anything clogging it.

I reassembled the bulb assembly, but the same thing happens which tells me I must have a clog somewhere.

Everything I've read seems to say I should get a carb kit and rebuild, but does anyone have any other suggestions?

Thanks!
 

Last edited by gunksny; 05-13-09 at 05:54 AM.
Sponsored Links
  #2  
Old 05-13-09, 06:47 AM
BFHFixit's Avatar
Banned. Rule And/Or Policy Violation
Join Date: Jun 2007
Location: USA.
Posts: 1,836
You could disconnect the fuel line from the inlet of the carb and try it. If you get the same result then kit and clean the carb. If not, it may be fuel line or fuel filter.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes