Welcome to the DoItYourself Forums!

To post questions, help other DIYers and reduce advertising (like the one on your left), join our DIY community. It's free!

Stihl FS55 Primer Bulb/Starting Problem


gunksny's Avatar
Member

Join Date: May 2009
Posts: 1

05-13-09, 05:39 AM   #1  
Stihl FS55 Primer Bulb/Starting Problem

hi -

I'm having trouble starting my FS55 weed trimmer. First thing I did was change the spark plug (man thats a tight fit with the wire in there!).

When I push the primer bulb, it stays pressed in and doesn't pop back up (there is fuel in it and the choke is on). After 45 min or so, its back to normal, and if I press it in, same thing happens.

I removed the 4 screws holding the bulb down and of course, this releases the vacuum. I pulled that plate off and the green fuel line off the brass L - fuel spilled out of the fuel line and I tried to push a wire into the brass L to see if there was anything clogging it.

I reassembled the bulb assembly, but the same thing happens which tells me I must have a clog somewhere.

Everything I've read seems to say I should get a carb kit and rebuild, but does anyone have any other suggestions?

Thanks!


Last edited by gunksny; 05-13-09 at 05:54 AM.
 
Sponsored Links
BFHFixit's Avatar
Forum Topic Moderator

Join Date: Jun 2007
Posts: 1,758
KS

05-13-09, 06:47 AM   #2  
You could disconnect the fuel line from the inlet of the carb and try it. If you get the same result then kit and clean the carb. If not, it may be fuel line or fuel filter.

 
Search this Thread