John Deere JX75 (Kawasaki 6HP) stalls -Suspect Dirty Carb.

Reply

  #1  
Old 05-13-09, 11:53 PM
Member
Thread Starter
Join Date: Nov 2003
Location: USA
Posts: 20
John Deere JX75 (Kawasaki 6HP) stalls -Suspect Dirty Carb.

Hi:

I have a John Deere JX75 walk behind mower powered by a Kawasaki 6HP motor (Mfg. 1998).

After sitting for a year, I took it out. While it started, it did not run well.(Had to leave choke on) It came close to stalling when the blade was engaged. I was able to cut with it, but eventually it stalled and will not restart.

It will start and run as long as I am spraying ether or carb cleaner in it. I suspect I have a dirty carburator.

I dropped the bowl and cleaned it out and refilled with fresh gas, it still will not start without spraying something in it.

Does anyone have any suggestions? I have taken apart these things before, but it has been over 15 years.

Thanks in advance.
 
Sponsored Links
  #2  
Old 05-14-09, 12:04 AM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 16,819
Take the carb off and clean out the jets and passages with a good spray carb cleaner and see if that does it. If not, you may have to soak it in a bath type cleaner.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes