Engine runs rough until warmed up

Reply

  #1  
Old 06-03-09, 06:43 AM
Member
Thread Starter
Join Date: Aug 2002
Location: new york
Posts: 356
Engine runs rough until warmed up

I have a Snapper riding lawnmower with a Briggs 6 hp engine. It is probably at least a 20 year old model, not sure how old the engine is. Anyways, it has been running good for the last few years however, it started doing the following. When you start it up the engine runs fine while idling, but when you put it in gear and engage the blade it will run good for 20 seconds or so then it will lose a bit of power, slow down a bit and sounds like it does when you have the choke on and it will stay like this for about 3-4 seconds and then will go back to running normally. This happens for about 10-15 minutes of use and then is fine for the next half hour or so that I run it. Any thoughts on what it could be. Thanks
 
Sponsored Links
  #2  
Old 06-03-09, 07:54 PM
indypower1's Avatar
Member
Join Date: May 2009
Location: Lake Winnipesaukee, New Hampshire
Posts: 634
sounds like the carb is plugged up somwhere. Since it does run,I would first try SeaFoam in the gas at the rate of 2oz. per gallon. You can buy SeaFoam at your local auto parts store.
 
  #3  
Old 06-03-09, 09:36 PM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 16,818
Does it smoke any at all when doing this? If so, is it black smoke? If so, check the air filter.
 
  #4  
Old 06-04-09, 12:13 PM
Banned. Rule And/Or Policy Violation
Join Date: May 2007
Location: Wisconsin
Posts: 8,629
Does this high of a HP motor still rely on that vane and springs to govern engine speed?

If so, I'd look for clogged grass anywhere, up in around the flywheel, trapped there by the plastic vane, and even under the mower deck. If that vane cannot freely move under correct spring tension (which also you may want to look at for any distortion, incorrect hook-up, etc.) then this will alter how it runs.

If the 6 HP does not rely on this method -sorry -just trying to help.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes