Cub cadet blades wont engage

Reply

  #1  
Old 06-04-09, 05:28 PM
Member
Thread Starter
Join Date: Jan 2009
Location: ohio
Posts: 9
Cub cadet blades wont engage

My blades all of sudden wont engage when i pull the knob on my cub cadet HDS 2185.. anyone know whats up?
 
Sponsored Links
  #2  
Old 06-04-09, 07:58 PM
hopkinsr2's Avatar
Member
Join Date: Feb 2005
Location: canada
Posts: 1,561
Have you looked @ it you're self yet??? Is the belt on it?? Have you hit anything with the blades?? (REMOVE the spark plugs before doing anything else, Please) Do all the spindles turn free & smooth???? (You'll have to release the blade brake for that one).. Are the blades straight & not hitting something under the deck?? Any funny noises before it quit??? Does it have an electric P.T.O?? Could be a fuse... If it has the cable, the cable may have broken,,, Just some things to check out, unfortunally you have to lie in the grass & feed the bugs to check most of them...LOL. Let us know what you see & we'll try to help some more.... Roger
 

Last edited by hopkinsr2; 06-04-09 at 08:06 PM. Reason: more questions
  #3  
Old 06-05-09, 12:33 PM
bontai Joe's Avatar
Member
Join Date: Apr 2004
Location: Pennsylvania
Posts: 592
I just had my 31 year old Deere do that. Seems 31 years of the power wire rubbing aganst the vibrationg motor wore it thru. Fixed the wire and I was good to go. Yours could be an unplugged wire, loose wire connection, blown fuse, short circuit, or a bad clutch. Gonna hafta check it out a little and see what you find.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes