Welcome to the DoItYourself Forums!

To post questions, help other DIYers and reduce advertising (like the one on your left), join our DIY community. It's free!

Toro lawn mower - self propel and start chain


shw104's Avatar
Member

Join Date: Aug 2005
Posts: 213
MD

06-20-09, 04:20 PM   #1  
Toro lawn mower - self propel and start chain

I have a 4 year old 22" Toro Recycler (Self Propelled) mower... it's been a great mower..

Lately.. i've noticed two issues.. 1st..after I pull the start cord, it doesn't always retract back into the housing. To me it sounds as a spring is going. It still starts fine but I'm waiting for the time with the cord will not retract at all. Any suggestions? How difficult is this assembly to replace?

Also, the past 3 weeks, i've lost power on the self Propelled wheels.. they still engage as normal but just start slower and have 1/3 of the power. Not a big deal as I need the exercise anyway but was wondering if anyone again had any suggestions? I don't think the belt is slipping but that is a possibility.

Thanks!!
Scott

 
Sponsored Links
cheese's Avatar
Forum Topic Moderator

Join Date: Jul 2001
Posts: 16,569
GA

06-20-09, 07:53 PM   #2  
Chances are the belt is slipping on the drive problem. There may be an adjustment to tighten the cable for the drive belt.

The starter cord rewind problem can probably be remedied by spraying some lube up in the center area of the rewind spool where it rotates on the shaft. You probably will have to remove the top engine cover and turn the rewind assembly upside down to get it lubed well.


"Who is John Galt?" - Ayn Rand (Atlas Shrugged)

God bless!

 
Search this Thread