craftsman electrical problem

Reply

  #1  
Old 06-20-09, 04:37 PM
Member
Thread Starter
Join Date: Jun 2009
Location: va
Posts: 1
Angry craftsman electrical problem

put new starter and battery on but still get just one loud click as key is turned. it did fire up on the second try after installing new starter but wont engage now.
 
Sponsored Links
  #2  
Old 06-20-09, 07:50 PM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 16,854
Is it getting power to the starter cable? Can you bridge the terminals of the solenoid to make it crank? Is the engine locked up? What do you have so we know what we're talking about?
 
  #3  
Old 06-20-09, 07:52 PM
hopkinsr2's Avatar
Member
Join Date: Feb 2005
Location: canada
Posts: 1,563
Do you have a model & Serial #,,Engine #'s??? Have you checked the voltage drop over the solonoid while cranking the engine?? Do you have any voltage @ the starter when you turn the key?? Kinda sounds like a solonoid,, But you should do some testing before throwing parts @ it. Even charge & load test the new battery....Post some numbers & the Pro's will help out soon,,, Good Luck,, Roger
 
  #4  
Old 06-21-09, 11:09 PM
Member
Join Date: May 2009
Location: St. Albans, Herts, UK
Posts: 95
Try taking the plug out and cranking it. Could be hydro locked.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes