problems with my McCulloch weedwacker

Reply

  #1  
Old 07-05-09, 09:01 AM
Member
Thread Starter
Join Date: May 2008
Location: united states
Posts: 45
problems with my McCulloch weedwacker

hi, I have a McCulloch weedwacker model #3227 and I can't get it to run . If I put it on the choke position I can get it to start, but it sputters and runs at a low idle as soon as I turn the choke off it revs up and stalls. The only way I can restart it is if I put the choke on and than I'm back in the same boat. thanks
 
Sponsored Links
  #2  
Old 07-05-09, 09:35 AM
Member
Join Date: Mar 2009
Location: British Columbia
Posts: 111
Fuel system is plugged with foreign material or stale gas. Either way, time for a carb o/h and new fuel filter. Unless you are prepared to do the work yourself, a new trimmer might be cheaper.
 
  #3  
Old 07-05-09, 11:02 AM
Member
Thread Starter
Join Date: May 2008
Location: united states
Posts: 45
this problem happened last year, and I replaced the fuel filter and put new gas in it but that didn't work. I already bought a new weedwacker but would still like to get this one going cause I have some attachments for it. I'll try taking the carb off and cleaning it but if you have any helpful suggestions I would appreciate it . thanks
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes