cub cadet drive problems

Reply

  #1  
Old 07-23-09, 02:09 PM
Member
Thread Starter
Join Date: Jul 2009
Location: United States
Posts: 2
cub cadet drive problems

hi,
involving much frustration due to corrosion around the drive shaft, i've just now gotten a new drive belt onto my Cub LT 1042. i was mowing recently, drive belt shredded after four years of use...when it did, the engine ran but the mower wouldn't budge. changed the belt, smile, get on the mower, crank her up, and she sits. no movement. all springs are attached and the belt is moving fine. when i raised the mower onto its rear wheels, i noticed oil/grease on the back plate of the mower just behind the hydro trans. it has leaked what i believe to be a good amount, although i am told that the trans fluid containers on this model are factory sealed and never need to be filled or changed. i suppose this is two questions:
A) what could cause the mower to not move with a new belt?
B) recognizing that the warranty is long gone, is this something CC should be responsible for?

thanks and i appreciate your time.
 
Sponsored Links
  #2  
Old 07-23-09, 02:55 PM
Member
Thread Starter
Join Date: Jul 2009
Location: United States
Posts: 2
i should note that this is an MTD model.

also, when i asked if this is something CC should be responsible for, i was referring to the hydro trans leak and i probably already know the answer to that question.
 
  #3  
Old 07-23-09, 07:15 PM
Member
Join Date: Feb 2008
Location: usa
Posts: 755
Post the model and serial number of your tractor and the brand and model number of the transaxle installed. With this information we can better reply to your problem. Also, how old is this tractor?
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes