New Ryobi Weed Eater Problem

Reply

  #1  
Old 08-01-09, 12:51 PM
Member
Thread Starter
Join Date: Aug 2009
Posts: 1
New Ryobi Weed Eater Problem

Unit began to die as though out of gas. Found cracked fule line and primer bulb - replaced both. Now will start only after priming cylinder with gas. Runs for a second then dies. Not getting gas. Thoughts?
 
Sponsored Links
  #2  
Old 08-01-09, 01:56 PM
Member
Join Date: Feb 2008
Location: usa
Posts: 755
I moved your post to a thread of its own. Multiple postings in a thread get confusing.

The title you used says "New". Is this a recently purchased unit or are you referring to a new problem?

Give of a model number, age of unit and history leading up to current problem. What brand and model number carburetor is installed on this unit.
 
  #3  
Old 08-01-09, 04:33 PM
hopkinsr2's Avatar
Member
Join Date: Feb 2005
Location: canada
Posts: 1,561
Airman has you on the right track... If this is a new unit,, Take it back for warranty... If it's a new problem & it's an older unit & the fuel lines & primer bulb are rotton,, so is the inside of the carb,, You'll need a carb rebuild kit & adjust the meetering lever & also make sure all the bolts around the cylinder & the rest of the engine are tight & the gaskets aren't leaking..... Roger
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes