Welcome to the DoItYourself Forums!

To post questions, help other DIYers and reduce advertising (like the one on your left), join our DIY community. It's free!

craftsman 6.75 mrs model#944.364372


cbleich's Avatar
Member

Join Date: Aug 2009
Posts: 1

08-18-09, 02:39 PM   #1  
craftsman 6.75 mrs model#944.364372

i bought this mower a couple years ago and then i hit a rock with it. i changed the shear key on the flywheel and put a new sparkplug in. i have cleaned the air filter. put a new blade on it(its a 20 " but the mower is a 21", will that matter?). i still cant get it to run up to full rpm. does anyone know what i could try next. i also have a 6.5 from the same year that is doing the same thing, its my brothers. need some help , my grass is getting long !!

 
Sponsored Links
31YTech's Avatar
Member

Join Date: Feb 2008
Posts: 1,263
FL

08-18-09, 05:22 PM   #2  
The blade difference will not hurt anything, You can try adjusting the high speed rpm's as below. If not careful mowing up under bushes ect. this tang can get pushed/bent in which causes high speed rpm's to drop.






Good Luck

 
Airman's Avatar
Member

Join Date: Feb 2008
Posts: 755
TN

08-18-09, 07:25 PM   #3  
31YTech,

You post great graphics. "A picture is worth a thousand words".

 
31YTech's Avatar
Member

Join Date: Feb 2008
Posts: 1,263
FL

08-18-09, 07:53 PM   #4  
Thanks Airman,

I try to do my best at making sure posters understand my replies so they can get their units back up asap.....


pssst.... I find it easier to make a pic if I don't already have one than to try explaining some things.

 
Search this Thread