Welcome to the DoItYourself Forums!

To post questions, help other DIYers and reduce advertising (like the one on your left), join our DIY community. It's free!

16 hp Kohler no spark


Douglas1967's Avatar
Member

Join Date: Aug 2009
Posts: 1

08-27-09, 03:28 PM   #1  
16 hp Kohler no spark

My friend has a 16 hp Kohler Engine on a Sears tractor that has no spark. He changed the coil with a new one got no spark. Tried it without the ground connected to the coil and still no spark,any ideas.He has checked all safety switches they are all ok. But with the ground not hooked up he should get a spark.

 
Sponsored Links
marbobj's Avatar
Member

Join Date: May 2006
Posts: 3,658
IA

08-27-09, 03:35 PM   #2  
He probably has an igniter on that one and it is bad. It's a little square box affair on a lead coming from the coil.

Get the model and serial numbers off the engine and post them back. We'll check it out.

 
31YTech's Avatar
Member

Join Date: Feb 2008
Posts: 1,263
FL

08-27-09, 03:54 PM   #3  
What did he set the coil to flywheel magnet air gap to ?


Rotate the flywheel magnet away from the coil. loosen the two mounting screws then pull the coil away from the flywheel and just snug the two screws.

Rotate the flywheel magnet in front of the coil and insert any business card between the coil and magnet. Loosen the two screws and let the magnet pull the coil to the flywheel, Hold a slight pressure on the coil pushing it against the flywheel then tighten the screws. Rotate the flywheel to remove the business card......

 
Square Head's Avatar
Member

Join Date: Jan 2005
Posts: 188
CANADA

08-31-09, 08:58 PM   #4  
The gap on that motor for the ignition is likely .018-.020''.
Be sure it's set correctly. Points and condenser?? or electronic ignition??

 
printer-man's Avatar
Member

Join Date: Aug 2009
Posts: 102

09-01-09, 12:33 PM   #5  
i get the impression that this has the cylindrical automotive style coil that`s on the older tractors.

it sounds as though the points are bad/out of adjustment.

 
cheese's Avatar
Forum Topic Moderator

Join Date: Jul 2001
Posts: 16,570
GA

09-01-09, 07:27 PM   #6  
The fact that the testing is done with no grounding wire connected to the coil tells us it's an armature/coil type module like found on the kohler commands. I suspect this is a model CV16S. If so, then I suspect the coil air gap is incorrect (should be .010"), or the coil was mounted upside down. More info (engine model) would be a help.


"Who is John Galt?" - Ayn Rand (Atlas Shrugged)

God bless!

 
Search this Thread