12.5 hp B&S won't engage blades

Reply

  #1  
Old 08-30-09, 05:56 PM
Member
Thread Starter
Join Date: Aug 2009
Location: Louisville, KY
Posts: 2
12.5 hp B&S won't engage blades

I have a 12.5 hp B&S engine on my riding mower. It starts fine and turns off fine. When I engage the blades, the engine dies. There is a wire coming out of the engine. I disconnected it and the blades will engage without killing the engine, but turning the key to the off position does nothing and I have to choke the engine out or reach down and touch the wires together or to metal (to ground it) in order to stop the engine. How can I have this wire connected and still engage the blades?
 
Sponsored Links
  #2  
Old 08-30-09, 06:35 PM
31YTech's Avatar
Member
Join Date: Feb 2008
Location: EveryWhere
Posts: 1,263
Without a tractor model number posted, There is a safety switch under the seat. If the connector is loose or the switch is faulty it will not detect you being in the seat and kill the engine when the deck is engaged.

The switch can be tested with a multimeter set on ohm's scale, Check for a opening/closing circuit as the switch is operated.



Good Luck
 
  #3  
Old 08-31-09, 01:57 PM
Member
Thread Starter
Join Date: Aug 2009
Location: Louisville, KY
Posts: 2
The tractor is a Toro Wheelhorse. My father purchased it at a yardsale. The motor doesn't look like it is what came with it and there seems to be several other modifications, the seat being one of those modifications, so that would explain it. At least now I have a better understanding of which direction to go in with this!

Thanks a bunch!
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes