Craftsman mower blades wont engage

Reply

  #1  
Old 09-13-09, 12:06 AM
Member
Thread Starter
Join Date: Sep 2009
Location: Al
Posts: 2
Craftsman mower blades wont engage

I have a Craftsman 17.5 HP 42" cut and the blades wont engage. The lever has spring pressure and works fine. The problem started gradually. At first it sort of delayed in engaging then would engage if the deck was jarred or bumped and now nothing. Any Ideas?
 
Sponsored Links
  #2  
Old 09-13-09, 01:31 AM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 16,821
The rollers on the ends of the blade brake arms are stuck. Get some pliers and WD40, spray them and work them loose until they spin freely. You may also need to spray the pivot bracket that moves the tensioner pulley into the belt and get it rotating freely.
 
  #3  
Old 09-13-09, 04:06 AM
Member
Thread Starter
Join Date: Sep 2009
Location: Al
Posts: 2
Smile

Thanks Cheese! Sounds like a plan. I'll give it a go. Thanks again.
 
  #4  
Old 09-14-09, 01:22 PM
Member
Join Date: Aug 2009
Location: Inverness, FL
Posts: 102
another good idea would be to check the belt and make sure it
is still good. a belt grips on the sides not the center.
if it is really cracked or hard & glazed looking you should re-place it.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes