Cub Cadet cc4125 not starting

Reply

  #1  
Old 09-19-09, 01:41 PM
Member
Thread Starter
Join Date: Sep 2009
Location: United States
Posts: 2
Cub Cadet cc4125 not starting

My Cub Cadet cc4125 string trimmer will not start. When pulling the pull cord, it comes out with no real resistance. Normally the EZ Start System would apply resistance after about 1-2 inches and not require much of a pull to start. Now, no reisstance and won't start. I replaced spark plug and no change.
Fresh gas, no change.
Any thoughts?
 
Sponsored Links
  #2  
Old 09-19-09, 08:48 PM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 16,814
Pull the spark plug out and see if it has compression when you crank the engine. Sounds like it doesn't. It could be a valve problem or a broken connecting rod. Was it run without oil?
 
  #3  
Old 10-06-09, 02:19 PM
Member
Thread Starter
Join Date: Sep 2009
Location: United States
Posts: 2
sorry for the delay in responding. Finally got a compression test done. zero pressure seen.
not sure if I should start with cylinder gasket or inspect the valves, or piston rings?
Thanks for the help.
 
  #4  
Old 10-06-09, 03:19 PM
Member
Join Date: Jul 2005
Location: Texas
Posts: 205
If this trimmer is a overhead valve,check the owners manual for valve specs. .They could be out of adjustment causing no compression,also check to see if the push rod came loose from the tappet.Hope this helps.

Jerry
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes