Ryobi Trimmer will NOT start

Reply

  #1  
Old 09-19-09, 03:37 PM
Member
Thread Starter
Join Date: Sep 2009
Location: Dallas Texas, USA
Posts: 2
Red face Ryobi Trimmer will NOT start

I have a Ryobi 725r trimmer that will not start. I replaced the tank along with all fuel lines etc. The plug is firing but it will not even crank or sputter. What am I missing???

Please help!
Thank you,
Mike
 
Sponsored Links
  #2  
Old 09-19-09, 08:43 PM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 16,821
Does it have good compression? Have you cleaned the carb?
 
  #3  
Old 09-20-09, 09:16 AM
Member
Thread Starter
Join Date: Sep 2009
Location: Dallas Texas, USA
Posts: 2
Originally Posted by cheese View Post
Does it have good compression? Have you cleaned the carb?
I am not sure if it has good compression. I dont know how to check that. I did dismantle the Zama Carb and sprayed it down with carb cleaner. After reassembling I tried it again. I tried it on half choke and it sputtered. I then tried it again on no choke and it turned over and ran for 3 to 5 seconds and then died. I re-primed it and it did it again. I am stumped.

Thanks
Mike
 
  #4  
Old 09-20-09, 05:56 PM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 16,821
Does the primer work well and circulate fuel through it?
 
  #5  
Old 09-22-09, 08:56 PM
hopkinsr2's Avatar
Member
Join Date: Feb 2005
Location: canada
Posts: 1,561
Have you put a carb kit in it & adjusted the meatering leaver to spec??? The Zama website has some awesome service manuals,,, Check them out... Roger
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes