Troy Bilt 01919 generator


  #1  
Old 09-24-09, 09:25 AM
G
Member
Thread Starter
Join Date: Sep 2009
Location: Florida
Posts: 2
Upvotes: 0
Received 0 Upvotes on 0 Posts
Troy Bilt 01919 generator

I have the 5550 generator and had the same thing happen after not starting the thing for a year! I pulled off the carb and soaked it clean and I ran seafoam also. It starts with one pull again but it still has a sputter or miss. Any suggestions? Also you can run the gas out of the carb by shutting the gas off till it stalls and then put on full choke and restart leaving the choke on till it stalls again. This will drain your carb of gas.Beer 4U2
 

Last edited by guitarslinger; 09-24-09 at 12:07 PM.
  #2  
Old 09-24-09, 05:40 PM
A
Member
Join Date: Feb 2008
Location: usa
Posts: 636
Upvotes: 0
Received 0 Upvotes on 0 Posts
If you have not installed a new spark plug install one.

Other than that I say the carburetor needs a more thorough cleaning. I am not a fan of immersion cleaners unless the carburetor is severely dirty and varnished. I prefer ultrasonic cleaning first and then aerosol cleaners followed up by blowing out with air.

Post the brand, model, etc. of the engine for more specific help?
 
  #3  
Old 09-24-09, 07:39 PM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 16,041
Received 156 Upvotes on 142 Posts
I agree, if it still spits with the new plug, the carb still needs a bit more cleaning.

Running it like you said won't clear the carb of all fuel. It will still have some in the bowl, just not as much.
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description: