Welcome to the DoItYourself Forums!

To post questions, help other DIYers and reduce advertising (like the one on your left), join our DIY community. It's free!

Suzuki SE300AD portable generator


Electric bafoon's Avatar
Member

Join Date: Nov 2009
Posts: 2

11-28-09, 07:04 PM   #1  
Suzuki SE300AD portable generator

I have a suzuki portable generator, model SE300AD. It puts out voltage sometimes, sometimes not. I've checked for burnt wires. None found. Checked all connects (without tearing generator down completely). All tight. It started producing electricity yesterday and this morning, but I turned off, restarted, get no electricity. I'm not electrically proficient, but am mechanically inclined. I have the owners manual with wiring schematics, so if anyone could give me a bit of guidence, I'll figure this issue out.

 
Sponsored Links
cheese's Avatar
Forum Topic Moderator

Join Date: Jul 2001
Posts: 16,574
GA

11-29-09, 01:50 AM   #2  
I don't know what is in that model to go bad, but I would guess that there is a connection problem or a relay type device that is not making contact all the time.


"Who is John Galt?" - Ayn Rand (Atlas Shrugged)

God bless!

 
Electric bafoon's Avatar
Member

Join Date: Nov 2009
Posts: 2

11-29-09, 09:39 AM   #3  
Thanks Cheese for your thoughts. They are appreciated.

 
cheese's Avatar
Forum Topic Moderator

Join Date: Jul 2001
Posts: 16,574
GA

11-29-09, 07:50 PM   #4  
Another thought is the grounds on the diodes may be loose or rusted? Possibly causing intermittent connection? I don't know, I'm not a generator expert but I've worked on several. I think we have a few members here who are more experienced with the electrical end of a generator, so check back often for new replies.


"Who is John Galt?" - Ayn Rand (Atlas Shrugged)

God bless!

 
Search this Thread