Pressure Washer has zero pressure, help!

Reply

  #1  
Old 12-26-09, 05:26 PM
Member
Thread Starter
Join Date: Dec 2009
Location: Indiana
Posts: 2
Pressure Washer has zero pressure, help!

I have a Briggs & Stratten Speed Clean pressure washer, 2 gpm, 2000psi, which I've used very little, but has always worked fine when I needed it. I have used it in the Winter before, with a five-gallon bucket of water and a hose for the water supply, no problem. This last time, though, I forgot to depress the trigger before starting it, as instructed, and it would not pump any water. I took the hose off, and still no water. Is it possible that failing to depress the trigger before starting ruined something? I took the manifold off so I could check out the unloader valve, but couldn't get it apart or figure it out. I was able to determine, by putting fingers over two of the holes in the manifold and blowing into the other hole, that the unloader valve is stuck open, but I can't figure out how the unloader valve comes apart. I don't want to break it. Can anyone help me with this?
Thanks,
Steve
 
Sponsored Links
  #2  
Old 12-27-09, 11:49 AM
Member
Join Date: Feb 2008
Location: usa
Posts: 755
What is the model number of the pressure washer?
 
  #3  
Old 12-27-09, 02:14 PM
Member
Thread Starter
Join Date: Dec 2009
Location: Indiana
Posts: 2
Originally Posted by Airman View Post
What is the model number of the pressure washer?
It's model #020211.
I played around with it a little again today, figured out how to remove the unloader valve, and found no blockage or debris. The ball moves freely. I took the manifold off again and tried blowing in while blocking the other openings, and the only one I can't get air to come out of is the high pressure hose tube. I don't know, it might take a lot more pressure to get air to come out there. there's a white plastic long cone-shaped piece in there that doesn't seem to come out.
 
Reply


Thread Tools
Search this Thread
Display Modes
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -7. The time now is 02:56 AM.