Welcome to the DoItYourself Forums!

To post questions, help other DIYers and reduce advertising (like the one on your left), join our DIY community. It's free!

Troy-Bilt WON'T START-NEW


Bondogirl's Avatar
Member

Join Date: Dec 2009
Posts: 3

12-28-09, 07:53 PM   #1  
Troy-Bilt WON'T START-NEW

I realize this was extremely stupid to do, but I purchased a Troy-Bilt Storm 9.5 28" Self-Propelled Snow Thrower in 2007, and never started it before this last big snow in Virginia.
I've tried everything. I'm a female but have worked on everything from lawnmowers to replacing motors in commercial carpet cleaners, and everything in between. I was brought up as a tomboy and know more about engines and male dominated hobbies than some men I know!
I have determined that there is no spark coming from the cord that fits over the spark plug. I did the handy screwdriver to contact to metal test. To me this isn't a good sign, but I thought perhaps someone who has snow thrower knowledge could help me troubleshoot.
I'm thinking it may be the coil but cannot find a schematic that shows where the heck the coil is located. I also wanted to price one but cannot find a link to that part on the MTD site. I suppose they want you to send it out for service instead of replacing it yourself!
My question is: The electric start works, but the engine will not run. MTD said it sounds like something is grounding it out. This stupid thing is brand new. Anyone have any suggestions as to how I can find out if it is the coil? Suggestions welcome and appreciated.
Also, yes I have the key in, gas, oil, correct choke and throttle position, and proper gauge extension cord.
Thank you, Bondogirl

 
Sponsored Links
aj-allen's Avatar
Member

Join Date: Nov 2005
Posts: 467
CO

12-28-09, 08:08 PM   #2  
It is most likely not the coil. I know that you said that you have the key in but it must be pushed in untill it snaps in. Check that and than put a tea spoon of gas into the spark plug hole put the plug back in and try to start it.

AJ

 
bontai Joe's Avatar
Member

Join Date: Apr 2004
Posts: 592
PA

12-29-09, 08:38 AM   #3  
If there is no spark, then unless there is mouse damage to the wiring, you have a loose wire or the key is not properly inserted or turned to the correct position.

 
the_tow_guy's Avatar
Group Moderator

Join Date: Feb 2001
Posts: 11,475
FL

12-29-09, 09:44 AM   #4  
I don't have much use for a snowblower , but any chance it's a safety switch of some kind like on a riding mower?


Measure it with a micrometer; cut it with an ax.

 
indypower1's Avatar
Member

Join Date: May 2009
Posts: 634
NH

12-29-09, 10:37 AM   #5  
Posted By: the_tow_guy I don't have much use for a snowblower , but any chance it's a safety switch of some kind like on a riding mower?
No saftey switches on snowblowers. They are closer to a push mower set up.

 
Bondogirl's Avatar
Member

Join Date: Dec 2009
Posts: 3

12-29-09, 04:05 PM   #6  
Thank you for the responses. The key is snapped in correctly. I called MTD today and although I am 1 month past my 2 year limited warranty they said they will fix something that was a factory problem.
I'm still thinking it's the coil since I have no spark from the plug wire, but I don't want to dismantle the thing to test the coil if they may cover it under warranty.
I'm taking it in tomorrow and when I get the verdit, I will post the result.
Thank you everyone for your responses.
Bongogirl

 
Search this Thread