Welcome to the DoItYourself Forums!

To post questions, help other DIYers and reduce advertising (like the one on your left), join our DIY community. It's free!

Craftsman Snowblower w/tracks wont self propel


dave29's Avatar
Member

Join Date: Dec 2009
Posts: 2

12-30-09, 10:16 AM   #1  
Craftsman Snowblower w/tracks wont self propel

Hi everyone im new here just looking for some advice ...i have a sears craftsman 2 steerable trac snowblower 8/26
model # c459-52128
when i pull the lever to move forward in any gear it just sits there sometimes i can move it by hitting the steering levers side to side...sometimes it works but slowly and wont go through heavy snow...i have to push it alot
machine runs good and throws snow well.
i cant find a manual or any info on it its about 7 years old maybe more..thanks for any info or tips

 
Sponsored Links
indypower1's Avatar
Member

Join Date: May 2009
Posts: 634
NH

12-30-09, 02:24 PM   #2  
I tried to find info on your snowblower. Sears Canada does not have the info that Sears U.S. has. I did make a phone call and found out your snowblower was made by "Technics". I did a search for that name and found nothing relating to snowblowers.

 
dave29's Avatar
Member

Join Date: Dec 2009
Posts: 2

12-30-09, 03:11 PM   #3  
thanks any idea what could cause these symptoms? i think its a chain drive not a belt...
i searched my number and got a mtd cross reference not sure if thats what make it is though

 
robonline's Avatar
Member

Join Date: Dec 2011
Posts: 1
Non-US

01-04-12, 03:58 PM   #4  
Steerable Trac.

Hi Dave.
I know this is an old thread but I was wondering if you solved your problem. I have the same machine and I think that you may need a new drive disk. It is a very simple job to do except if it is cold when you work on the machine. The cold always adds to difficulty level. Also If you want the manual I can scan it and email it to you.
If you still have this machine and it is still not working, I could sure a few of the parts from it as mine is now down.
Thanks.
Rob.

 
Search this Thread