B&S voltage regulator

Reply

  #1  
Old 01-03-10, 02:55 PM
Member
Thread Starter
Join Date: Jan 2010
Location: MA
Posts: 1
B&S voltage regulator

Have a B&S 20G414 running Simplicity snowblower. Voltage regulator 698315 has output of 13.5 vdc at idle and 14.6+- vdc at full speed. Blowing 1156 single contact bulb at full power??
Any thoughts as to output of vr or rating on bulb?

tks js
 
Sponsored Links
  #2  
Old 01-03-10, 04:48 PM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 16,815
Your voltage is fine. I suspect low-grade (chinese) bulbs and/or excessive vibration causing the bulbs to blow.
 
  #3  
Old 02-02-11, 02:08 PM
Member
Join Date: Feb 2011
Location: USA
Posts: 2
Any Luck, Have same problem

Can you let me know what you figured out. I'm having the same problem! I got 20amps at the bulb at first start up then 14 at idle.. Blew 3 bulbs so far
Thanks
Steve
 
  #4  
Old 02-04-11, 01:36 PM
Member
Join Date: Oct 2007
Location: ontario,canada
Posts: 325
Originally Posted by spolleypt View Post
Can you let me know what you figured out. I'm having the same problem! I got 20amps at the bulb at first start up then 14 at idle.. Blew 3 bulbs so far
Thanks
Steve
amps or volts ?
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes