New Kohler engine UPDATEII

Reply

  #1  
Old 05-31-00, 06:53 PM
Visiting Guest
Posts: n/a
Question

Newest update to my Kohler engine prob. To recap the problem:

My new (3 weeks old at the time) Sears Garden tractor w/22 HP Kohler CommandPro engine ran fine the first couple of times I used it. However, by the 3rd or 4th time, I had to choke it slightly to keep it running. It kept idling high and low. Like a pulsating.

The 1st Sears tech. came out, took the carb. apart, put it back together and it ran a little rough, but better until I cut the grass again. The same prob. cropped up.

A week later, the 2nd Sears tech. inspected it and ordered a carb. and a fuel pump. The carb. came in a few days later, but the fuel pump never showed up. Sears kept asking if I got it yet, but never did, so they re-ordered the pump. It has now been 3 weeks since the 2nd tech. came out.

While waiting for the new pump and carb., I cut the grass a few more times. Sunday I was cutting the grass with the choke slightly pulled so it wouldn't pulsate and out of the blue it starts acting funny. I pushed the choke all the way in and it ran fine. I idled down the engine after disengaging the blades and again, it ran fine. I cut more grass on Monday and it ran fine w/o having to choke it at all.

So now without changing anything, it appears to have corrected itself. Could it be an intermittent electrical prob. or do you think there was a foreign particulate wedged in the carburator that finally knocked loose?

Now that it's running ok, I'm going to wait until the fuel pump finally gets here. In the meantime I'll be cutting the grass a few more times to ensure the problem doesn't reoccur. Any other concerns I should look for?

Thanks for all your help so far!

Scott
 
Sponsored Links
  #2  
Old 05-31-00, 09:23 PM
Visiting Guest
Posts: n/a
Smile

Hi:Scott Rendall

Thanks for the follow up with the mower. However, I would not suggest you consider the problem permanately corrected just yet.

It just may be a faulty fuel pump, a minor restriction some where in the fuel system that for the time being appears to be okay. May also be an electricial problem at the fuel pump or ignition switch, etc. A loose connection maybe.

May be the sticky governor linkage mentioned prior. Check and clean, without removing, the linkage both at the carb and to the lever where the linkage connects opposite the carb.

Check and clean, as needed and if needed, the air filter. Also check for loose wiring at all connections.

Since the Sears rep will be coming out anyway, let him/her check it over once again while you wait, watch and sip on a tall cool beer.

Good Luck,
TomBartco
 
  #3  
Old 12-19-10, 09:13 PM
Member
Join Date: Feb 2008
Location: USA
Posts: 15
I had a 20 hp Kohler problem like that. Tried fuel filter. pump, carb. Found it ran fine with an auxilary gas tank. Turns out grass clippings in the tank gas feed were choking it off. Bruce Roe
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes