Welcome to the DoItYourself Forums!

To post questions, help other DIYers and reduce advertising (like the one on your left), join our DIY community. It's free!

yard machines snow thrower.....auger won't engage


georgem404's Avatar
Member

Join Date: Feb 2010
Posts: 1

02-10-10, 06:00 PM   #1  
yard machines snow thrower.....auger won't engage

i have a yard machines 2 stage snow thower......i had the auger bind-up due to the auger shroud bending and keeping the auger from rotating......unfortunately, i didn't realize the cause until several attempts to clean the impeller / auger etc of ice/slush etc while attempting to engage the auger several times.......after finding the real problem, i straightened the cover, (no more binding), but the auger did not resume turning......shear bolts look fine, cable is ok i think (even pulled it manually to make sure it wasn't stretched).........did i over-stress something with my multiple attempts to engage the auger despite it being jammed?.......could the belts have broken or jumped off the pully?...any gears to strip?....any experience with such a problem?.......any help would be appreciated....thanks, george note: i can freely move the impeller with my hand which turns the auger as well....just can't get it to engage via lever depression

 
Sponsored Links
hopkinsr2's Avatar
Member

Join Date: Feb 2005
Posts: 1,561
Non-US

02-11-10, 08:33 AM   #2  
Remove the belt cover & inspect the belts... I suspect you'll find then burned off.. Also watch the linkage move as you work the handle to verify the spring on the end of the cable isn't broken.... Roger

 
Search this Thread