Welcome to the DoItYourself Forums!

To post questions, help other DIYers and reduce advertising (like the one on your left), join our DIY community. It's free!

John Deere L110 Tractor


Jimmy31's Avatar
Member

Join Date: Apr 2010
Posts: 2

04-09-10, 05:06 AM   #1  
John Deere L110 Tractor

I have a John Deere L110 tractor, when the mower deck is lowered the blades lose speed. When the deck is all the way up it works fine, as soon as you lower the deck the power on the blades slows down. I already changed the belt, increased the tension on the belt, and checked the idler arm.

Any thoughts?

 
Sponsored Links
idmason60's Avatar
Member

Join Date: Oct 2005
Posts: 274
FL

04-09-10, 05:41 AM   #2  
Its usual for the engine,deck to slow down when load is applied but if only the blades slow and not then engine that indicates slippage of some sort. Does that model have a electric pto that controls the blades or mechanical? If electric it could be slipping if mechanical it might need adjusting for tension when engaged.

 
Jimmy31's Avatar
Member

Join Date: Apr 2010
Posts: 2

04-09-10, 07:21 AM   #3  
John Deere L110

Posted By: idmason60 Its usual for the engine,deck to slow down when load is applied but if only the blades slow and not then engine that indicates slippage of some sort. Does that model have a electric pto that controls the blades or mechanical? If electric it could be slipping if mechanical it might need adjusting for tension when engaged.
Only the blades slow, not the engine. PTO is not electric.

 
cheese's Avatar
Forum Topic Moderator

Join Date: Jul 2001
Posts: 16,567
GA

04-10-10, 01:23 AM   #4  
How tight is the belt with the deck down and the blades engaged? Sounds like not tight enough.


"Who is John Galt?" - Ayn Rand (Atlas Shrugged)

God bless!

 
Search this Thread