Welcome to the DoItYourself Forums!

To post questions, help other DIYers and reduce advertising (like the one on your left), join our DIY community. It's free!

Northstar Pressure Washer not spraying solution


Smith978's Avatar
Member

Join Date: Dec 2006
Posts: 24
FL

04-30-10, 07:47 AM   #1  
Northstar Pressure Washer not spraying solution

I have a Northstar model M1578112G 3000 PSI pressure washer. The pressure washer works fine, unless I try to use the chemical injector line. It sprays water just fine, but will not draw chemical solution from the chemical hose into the system. I tried all the normal solutions, no clogs present in the line, the pump has oil, proper nozzle, etc. Any ideas? I really don't want to lug this thing back to the store......

 
Sponsored Links
marksr's Avatar
Forum Topic Moderator

Join Date: Mar 2005
Posts: 42,802
TN

04-30-10, 09:08 AM   #2  
I never use the siphon feature on my PWer as I feel using a pump up garden sprayer does a better job and is better for the pump ..... but if I remember correctly, they won't siphon under pressure. Try the siphon without having the pressure on.


retired painter/contractor avid DIYer

 
Smith978's Avatar
Member

Join Date: Dec 2006
Posts: 24
FL

04-30-10, 09:25 AM   #3  
I'm not sure exactly what you mean. I have the garden hose connected to my pump inlet, the pressure hose and spray gun connected to my pump outlet and the chemical hose submerged in a bucket of cleaning solution. How do I turn the pressure off??

 
marksr's Avatar
Forum Topic Moderator

Join Date: Mar 2005
Posts: 42,802
TN

04-30-10, 02:43 PM   #4  
cut off the motor

need more characters


retired painter/contractor avid DIYer

 
cheese's Avatar
Forum Topic Moderator

Join Date: Jul 2001
Posts: 16,570
GA

04-30-10, 03:48 PM   #5  
Correct, it is not supposed to siphon chemicals while it is pumping high pressure.


"Who is John Galt?" - Ayn Rand (Atlas Shrugged)

God bless!

 
Search this Thread