Kohler Lawn mower engine

Reply

  #1  
Old 05-04-10, 11:13 AM
Member
Thread Starter
Join Date: Dec 2005
Location: USA
Posts: 3,188
Kohler Lawn mower engine

I have a riding mower with a Kohler SV715 engine. The engine has 32 hours running time. For the last couple of uses it has run a little rough at high RPM and when under load.

Today it was much worse. The engine misses and backfires (thick black smoke) and the exhaust fumes are eye watering. It feels like both RPMs and power are very low. The engine seems to idle OK and it runs fairly smooth at low speeds unloaded.

At the start of the season I changed the oil and replaced the air filter. I checked the plugs and they were clean and not worn. I did not replace the in line fuel filter. Is dirty gas the most probable cause of the problem? Anything else I should look for?

I just filled the tank and I don't want to empty it unless I have to.
 
Sponsored Links
  #2  
Old 05-04-10, 10:58 PM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 16,821
Sounds like the choke is stuck closed or the air filter is clogged, causing a very rich running condition.
 
  #3  
Old 05-06-10, 09:31 AM
Member
Thread Starter
Join Date: Dec 2005
Location: USA
Posts: 3,188
Cheese - Thanks for the quick reply. Yesterday I removed the prefilter (it only had 4-5 hours on it) and the engine ran a bit smoother. I also replaced the gas line filter which did have some crud in it. It's not backfiring like it was but it still misses and seems to lack power. The missing is mostly for the 1st 3 or 4 minutes after the PTO is engaged.

The engine doesn't have a separate choke, just a throttle. It purrs at RPMs mid range and lower. I'm thinking that maybe it is just bad gas or crud in the carburator. Do you have any other suggestions?
 
  #4  
Old 05-07-10, 10:53 PM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 16,821
I would agree that the carb probably needs cleaning.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes