Welcome to the DoItYourself Forums!

To post questions, help other DIYers and reduce advertising (like the one on your left), join our DIY community. It's free!

Troy Built Tiller with B&S does not stay running


sa116's Avatar
Member

Join Date: Nov 2009
Posts: 9
PA

05-04-10, 05:30 PM   #1  
Troy Built Tiller with B&S does not stay running

Hi I have a troy built Super bronco with an Briggs and Stratton INTEK I/C 206. Im having trouble with the carburetor I replaced it last year but this year the carburetor will not keep the engine running. I have sprayed carb cleaning into carburetor the engine will start but only run for a few seconds. Please any help in this. Is it just an adjustment??

Thank You

 
Sponsored Links
SeattlePioneer's Avatar
Banned. Rule And/Or Policy Violation

Join Date: Jul 2007
Posts: 5,503
WA

05-04-10, 07:22 PM   #2  
Sounds like you need to disassemble and do a more thorough job of cleaning the carburetor.

I like to suggest trying u-tube for videos of people cleanings Briggs carburetors if you aren't familiar with how to do that.

If you watch several you will probably find some people doing a good job, and you'll see some people doing a poor job too.

 
geogrubb's Avatar
Member

Join Date: Jun 2006
Posts: 2,333
MO

05-04-10, 07:44 PM   #3  
Posted By: sa116 Hi I have a troy built Super bronco with an Briggs and Stratton INTEK I/C 206. Im having trouble with the carburetor I replaced it last year but this year the carburetor will not keep the engine running. I have sprayed carb cleaning into carburetor the engine will start but only run for a few seconds. Please any help in this. Is it just an adjustment??

Thank You
Post the engine model, type and code numbers usually found on the metal shroud just above the spark plug or on a tag over the muffler, so we know what engine you have. Have a good one. Geo

 
Search this Thread