Husqvarna 650rtta rear tine tiller???

Reply

  #1  
Old 05-24-10, 04:33 PM
5dollaralien's Avatar
Member
Thread Starter
Join Date: May 2009
Location: roanoke valley/Franklin county
Posts: 126
Question Husqvarna 650rtta rear tine tiller???

Hi,
another friend has brought me this tiller and I thought I would ask a question first before I tear into it.
The drive works great in reverse and the tines run but the drive in forward slips/ or does not pull continuously. The belt tension seems fine and I adjusted it tighter just to be sure but works in reverse no problems. The pulley and shaft is turning ok.
any ideas??
I am thinking that I need to go into transmission to find the problem but before I do I wanted to consult you guys.
here is the manual
http://weborder.husqvarna.com/order_...3_O0302042.pdf
 
Sponsored Links
  #2  
Old 05-25-10, 12:16 AM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 16,814
That thing is a pain to take apart...everything has to come off before you can open the chain case. That said, if the belt is tight and working properly, the chain and sprockets inside are probably worn.
 
  #3  
Old 05-25-10, 01:53 AM
5dollaralien's Avatar
Member
Thread Starter
Join Date: May 2009
Location: roanoke valley/Franklin county
Posts: 126
thanks Cheese,
looking at the schematic and at the unit it looks as if it would be a big job that is going to take up space in my little workshop while finding the exact problem and ordering parts and then assembly. I try to help my friends as much as possible but I might not want to do this one. Of course it would be new to me and a learning project.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes