Craftsman Power Washer

Reply

  #1  
Old 05-25-10, 06:32 AM
Member
Thread Starter
Join Date: May 2010
Location: USA
Posts: 3
Craftsman Power Washer

I have a Craftsman Power Washer Model 580.752191 which I purchases in 2009 but did not use only added the oil. I tried to start the washer on Sunday and would not start. One monday it started and ran for only 30 minutes and then would not start. Any suggestions?
 
Sponsored Links
  #2  
Old 05-25-10, 07:33 AM
Gunguy45's Avatar
Super Moderator
Join Date: Dec 2007
Location: USA
Posts: 20,979
Did it have gas in it since 2009? If it did, it probably needs to be drained and refilled with fresh. Drain it completely, including the carb. Add some Seafoam (available at auto parts stores) and see how it goes.

When it ran for the 30 min, did it stop on its own..or did you stop it, then it wouldn't fire?

Do you have spark?
 
  #3  
Old 05-25-10, 08:01 AM
Member
Thread Starter
Join Date: May 2010
Location: USA
Posts: 3
Power Washer

I had not gas in the power washer and the machine stopped on its own.
 
  #4  
Old 05-25-10, 08:19 AM
bontai Joe's Avatar
Member
Join Date: Apr 2004
Location: Pennsylvania
Posts: 592
I'm sorry, but I gotta ask, did you check to see if the fuel tank is empty? I know some are small enough that a half hour under load will run 'em dry.
 
  #5  
Old 05-25-10, 08:32 AM
Gunguy45's Avatar
Super Moderator
Join Date: Dec 2007
Location: USA
Posts: 20,979
And it may have a low oil shutdown? Sometimes new engines use oil more quickly I believe??

Spark and fuel would be the first things to check.
 
  #6  
Old 05-26-10, 04:41 AM
Member
Thread Starter
Join Date: May 2010
Location: USA
Posts: 3
Powerwasher

Never started. Took back to Sears as under warranty. Sending off to get fixed. Had plenty of gas and oil. Sears also tried to start.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes