Welcome to the DoItYourself Forums!

To post questions, help other DIYers and reduce advertising (like the one on your left), join our DIY community. It's free!

Erratic idle on a 3.75HP Briggs & Stratton


gergstuff's Avatar
Member

Join Date: May 2010
Posts: 8
WA

05-27-10, 12:55 PM   #1  
Erratic idle on a 3.75HP Briggs & Stratton

Hello,

I have a lawn edger powered by a 3.75 hp Briggs & Stratton engine.

It had been running just fine and all of a sudden it lost power then developed a erratic speed. Normal speed then loss of power, normal speed then loss of power back and forth back and forth.

It seems likely it has something to do with the carburetor but before I go charging in there like a bull in a china shop I thought I had better seek the input of those who actually know what they are talking about.

Thanks,
Craig

 
Sponsored Links
indypower1's Avatar
Member

Join Date: May 2009
Posts: 634
NH

05-27-10, 01:08 PM   #2  
Sounds like a little bit of dirt got in the gas tank and found its way into the carb. Carb need to be cleaned.

 
geogrubb's Avatar
Member

Join Date: Jun 2006
Posts: 2,333
MO

05-27-10, 06:36 PM   #3  
Post the engine model type and code numbers usually found stamped in the metal engine shroud just above the spark plug and someone will get you going. Have a good one. Geo

 
gergstuff's Avatar
Member

Join Date: May 2010
Posts: 8
WA

05-28-10, 07:52 AM   #4  
Well, I took the carburetor off and gave it a compete cleaning. Flushed out the gas tank too. Put it all back together and voila! Back to normal. Must have been a little speck of crud causing all that trouble.
Thanks for the help.
Craig

 
Search this Thread