Welcome to the DoItYourself Forums!

To post questions, help other DIYers and reduce advertising (like the one on your left), join our DIY community. It's free!

Rough Idle-Ryobi Trimmer CS30-Help


glassc's Avatar
Member

Join Date: May 2010
Posts: 27
KS

05-29-10, 08:00 AM   #1  
Rough Idle-Ryobi Trimmer CS30-Help

I have a Ryobi CS30 string trimmer Model RY30020B year 2005.

It will start fine and idle. After running a few minutes you use it to cut and release to idle it will die out. The spark plug looks fine, air filter is clean, gas mix is fresh. When acclerating it is still missing and running rough. Whwn you let go it will die out. I need some good starting points. It will even do this with the spool head off too. Starts great. Need help.

 
Sponsored Links
cheese's Avatar
Forum Topic Moderator

Join Date: Jul 2001
Posts: 16,567
GA

05-29-10, 10:12 AM   #2  
Sounds like carburetor trouble. Check the fuel lines and primer for cracks/holes and if none, open the carb and clean it out.


"Who is John Galt?" - Ayn Rand (Atlas Shrugged)

God bless!

 
glassc's Avatar
Member

Join Date: May 2010
Posts: 27
KS

05-30-10, 04:43 PM   #3  
Cheese -- any information on instructions of opening up the carburetor? Any video links or instructions? Thanks

 
hopkinsr2's Avatar
Member

Join Date: Feb 2005
Posts: 1,561
Non-US

05-30-10, 08:56 PM   #4  
Take it apart & put a kit in it.. When you find out the manufacturer of the carb, go to there website, Most of them have a manual online & they will help you a lot... Roger

 
glassc's Avatar
Member

Join Date: May 2010
Posts: 27
KS

05-31-10, 12:50 PM   #5  
It is a WalBro looks like a number on it of 512.

 
Search this Thread