Husky chainsaw only runs with choke on

Reply

  #1  
Old 06-02-10, 04:00 PM
Member
Thread Starter
Join Date: Jun 2007
Location: Ludlow, MA
Posts: 172
Husky chainsaw only runs with choke on

Long story short...

My Husky 55 rancher ran great for 5 years until I burnt the top end on my chainsaw one lovely evening. I put on a new ring piston and jug, but it wouldn't run right. Have since put on a new...

Fuel line
Fuel filter
Air filter
Completly rebuilt the carb twice
Spark plug
Checked the gas vent
Carb mounting plate and gasket (stripped the old one)
Cleaned the Muffler

Now it only runs with the choke on. And runs pretty decent, at that. The only things left that I can think of are either I should just buy a whole new carb all together. or some people were saying if I burnt the top end, I probably burnt the bottom end seals. Would this cause such behavior? Do either of these sound like they could be the problem?

I've been pulling my hair out over this. I would really appreciate any help. Thank you.
 
Sponsored Links
  #2  
Old 06-02-10, 04:27 PM
BFHFixit's Avatar
Forum Topic Moderator
Join Date: Jun 2007
Location: USA.
Posts: 1,764
Ya the crank seals could cause it to run lean. When you choke it you cut down the air intake.
Sounds like you got the carb and intake covered.
 
  #3  
Old 06-02-10, 05:59 PM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 16,575
Crank seals is the place to look. Take a good look at the crank bearings while you're there too, they can get damaged when the saw gets toasted too.
 
Reply


Thread Tools
Search this Thread
Display Modes
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -7. The time now is 07:31 PM.