John Deere JX75 any suggestions

Reply

  #1  
Old 06-10-10, 10:41 AM
Member
Thread Starter
Join Date: Feb 2007
Location: new york
Posts: 165
John Deere JX75 any suggestions

Afternoon,
Before I load her up & get screwed at the John Deere place just looking for any suggestions. So far I took the carburetor all apart I mean everything & soaked it overnight in a can of carb cleaner. I adjusted the cable put everything back on tried it this morning & she is still running rough & only runs on high. When I take the blade clutch off (blade turning) she runs fine.
What I am noticing is the throttle plate rod & spring that goes to the governor arm is moving back & forth the whole arm which in turn pulls the throttle plate on the carb open & close.
Two things I could really use some help on! First is there an adjustment for the rod that is attached to the governor? (why I ask this is maybe a spring is not doing it's job. Second could it be the carb? I see where I can buy a new carb off John Deere for $110. & last could it be a spring that is worn? any other suggestions would really be very helpful?
As she is blackening up spark plugs in 10 min. & on a full tank of gas I can only cut the front where last summer I could cut the whole yard twice on a tank of gas. So I'm stumped on this one I do have a good spark.
Thank you for any & all help!
Will,
 
Sponsored Links
  #2  
Old 06-10-10, 12:31 PM
indypower1's Avatar
Member
Join Date: May 2009
Location: Lake Winnipesaukee, New Hampshire
Posts: 634
Have you adjusted the valves?
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes