Welcome to the DoItYourself Forums!

To post questions, help other DIYers and reduce advertising (like the one on your left), join our DIY community. It's free!

Dixon ZTR Model 429 made 1989


DaDude's Avatar
Member

Join Date: Jun 2010
Posts: 5
SD

06-11-10, 10:21 AM   #1  
Dixon ZTR Model 429 made 1989

Put new starter in and ignition switch and still cannot get it to turn over. It will start if I pull it but turn the key and nothing happens, sometimes the lights work when I turn the key on and sometimes they won't. Has a Kawasaki FC420V Engine and I'm Wondering if there is a Jumper Wire or is it a switch? Really need help, is there a Dixon Mechanic Out There, If So Help!!!!!!!!

 
Sponsored Links
indypower1's Avatar
Member

Join Date: May 2009
Posts: 634
NH

06-11-10, 11:02 AM   #2  
Have you checked the battery? How many volts does the battery show?

 
DaDude's Avatar
Member

Join Date: Jun 2010
Posts: 5
SD

06-12-10, 07:24 AM   #3  
Voltage

Bought New Charger and shows still charging at 2amp. but also shows 100%. Now for the Voltage Answer the New Charger has a Volt meter on it and shows, 15amp=16v, 10amp=16, 2amp=16v. What's going on? Thanks


Last edited by DaDude; 06-12-10 at 08:53 AM.
 
cheese's Avatar
Forum Topic Moderator

Join Date: Jul 2001
Posts: 16,567
GA

06-13-10, 12:13 AM   #4  
Those readings don't show what the battery voltage is except for when the charger is charging. Are the battery terminals and connections clean and tight?


"Who is John Galt?" - Ayn Rand (Atlas Shrugged)

God bless!

 
DaDude's Avatar
Member

Join Date: Jun 2010
Posts: 5
SD

06-14-10, 10:38 AM   #5  
Found Problem

Thanks for your help, found out the ignition switch was acting strange, turned the key just past run a little bit and it took off, turned it all the way to start and nothing, it seems that I got a bad switch or a really touchy one and the later seems to be what I got. Terminals are clean now. Thanks Much

 
Search this Thread