Welcome to the DoItYourself Forums!

To post questions, help other DIYers and reduce advertising (like the one on your left), join our DIY community. It's free!

Craftsman LT 2000 Wont Start


lawngator's Avatar
Member

Join Date: Jul 2010
Posts: 2
GA

07-02-10, 01:21 PM   #1  
Craftsman LT 2000 Wont Start

Craftsman LT 2000 Koeler 17HP OHV 6-7 years old. Tractor has been running fine all year. This weekend, I tried to crank it and ignition sounded fine. However, engine turns over but wont start. Thought it could be fuel problem. Tried starter fluid in carb but this did not work. Replaced plug, fuel filter and air filter but did not help. Oil is fine.

Noticed last time I ran it, the engine backfired but I did not think it was a problem. Also, when trying to crank now, I do get a slight backfire when it is trying to catch..

Any idea what might be causing this? Rings? Expensive?

 
Sponsored Links
hopkinsr2's Avatar
Member

Join Date: Feb 2005
Posts: 1,561
Non-US

07-02-10, 08:19 PM   #2  
Do you have spark??,,, Sometimes backfiring is fuel related,,But can also be spark... Let us know as it may help the pro's a lot.... Roger

 
BFHFixit's Avatar
Forum Topic Moderator

Join Date: Jun 2007
Posts: 1,761
KS

07-02-10, 09:21 PM   #3  
Pull the valve cover off and see if the pushrods are still in place, check valve clearance.

 
5dollaralien's Avatar
Member

Join Date: May 2009
Posts: 126
VA

07-03-10, 05:24 AM   #4  
check for spark, and for compression. the fuel but you are spraying it with starter fluid so when all is good it should fire.
It should be hard to hold compression on the motor. If all else fails check the shear pin on the flywheel, this will cause it not to start and backfire and such.

 
CAMINO KID's Avatar
Member

Join Date: Mar 2007
Posts: 354
WI

07-03-10, 05:03 PM   #5  
I had a Kohler that acted like yours with the back fire and for some reason sheared the flywheel key.

 
cheese's Avatar
Forum Topic Moderator

Join Date: Jul 2001
Posts: 16,567
GA

07-05-10, 11:45 PM   #6  
I agree... check the flywheel key.


"Who is John Galt?" - Ayn Rand (Atlas Shrugged)

God bless!

 
lawngator's Avatar
Member

Join Date: Jul 2010
Posts: 2
GA

07-08-10, 09:07 AM   #7  
Solved

It was the flywheel key. It had sheared. Good to go now. Thanks to all of you!

 
Search this Thread