Briggs and Straton 17.5HP smoking

Reply

  #1  
Old 10-17-10, 03:44 PM
Member
Thread Starter
Join Date: Jan 2005
Location: McDonough, GA
Posts: 90
Briggs and Straton 17.5HP smoking

Hi,

I have a Craftsman lawn tractor with a 17.5HP B&S engine on it. It has been running great, however, I have experienced a backfire or two while cutting the grass.

About 3-4 weeks ago, I went to crank the lawn mower up and it was hesitating to crank. I finally got it cranked. That night, we put it back in the garage. The next day, I noticed that the garage reeked of gas and noticed it all came from the carburetor.

Today, I went to crank up the lawn mower and it was still hesitating. I pulled the plug and noticed oil on the plug. It is not saturated in oil. As I was riding it around today, I noticed an occasional cloud of white smoke coming from the exhaust. I also noticed that it finally stopped blowing out white smoke. I then engaged the blades to cut a little grass and the white smoke came back.

Is this a sign that I need to drain the oil, possibly pull the carb, or look at the air filter?

Upon looking at the air filter last time it happened, it was still clean. I have not changed the oil, replaced the plug, or replaced the filter.

Thanks,
 
Sponsored Links
  #2  
Old 10-17-10, 05:18 PM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 16,629
Your engine is full of gas. The carb needle is leaking gas into the oil. Take the carb bowl off and clean it out, replace the needle if needed, then drain the gassy oil and refill. Don't run the engine anymore with the gassy oil in it...it will ruin it.
 
  #3  
Old 04-11-12, 12:02 PM
Member
Join Date: Apr 2012
Posts: 1
I have an craftsman riding lawn mower 2000 917.288031, I used it this year and cut grass but last week white smoke came out when I was on the hill side, then after I hit a whole in the neighbor yard all it will do is crank over, but won't start, I changed fuel filter, oil, put fresh gas in, but still cranks over but won't start, someone said to check a fuse, but I can't find it, can you help, my mechanic is in Qwaitt he has been trying to help me, but nothing works.
 
Reply


Thread Tools
Search this Thread
Display Modes
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -7. The time now is 12:32 AM.