Homelite weed wacker will not run

Reply

  #1  
Old 11-20-10, 02:46 PM
Member
Thread Starter
Join Date: Nov 2010
Location: USA
Posts: 1
Homelite weed wacker will not run

I have a Homelite UT2004A. After I push primer bulb a few times, it will run for a few seconds then die. The primer bulb fills very slowly how do I fix it?
 
Sponsored Links
  #2  
Old 12-09-10, 08:48 AM
Member
Join Date: Nov 2010
Location: USA
Posts: 7
Restricted fuel delivery or gummed carburetor

Sounds to me like your carburetor has issues or there is a pinched fuel line. If the carburetor is being starved of gasoline, it wont continue to run. That first supply of gas provided to the carburetor by the primer will start it but if the jets are clogged or the diaphragm is faulty it wont run long. Stale fuel that may have been introduced into the carb will cause this. If you can remove the carb then disassemble it you will find a "diaphragm" inside that pumps the fuel to the carb. Use Carburetor cleaner to remove any debris and varnish. Check the diaphragm to make sure its supple to the touch, if not use wd40 to soften it up. (replace if necessary). Check both fuel lines to make sure there are no pinched lines and that you see that fuel is traveling freely. Let me know if that helps.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes